ApplicationXtender - Desktop - Unable to Save Query
Applies to
ApplicationXtender Desktop 6.0, 6.5, 7.0, 8.0, 8.1, 16.3, 16.6
Summary
Unable to Save Query in AX Application.
Symptoms
Unable to Save Query in AX Application. When saving a query the following error is thrown:
CODE=80004005 error description DB-0024 "Unable to lock database"
Cause
AppXtender Desktop could possibly have crashed while saving a query, not releasing the lock on the database in the ae_cfg table.
Resolution
1. The following script needs to be run against the ae_cfg table in the AX database:
UPDATE ae_cfg SET cfgid =100 WHERE cfgid =-100;
OR
2. Manually open the ae_cfg table and look for a negative integer in "cfgid" column.
Warning: Only experienced Database Administrators should make modifications to the database. The result of an inexperienced user modifying the database could be disastrous. CASO recommends backing up the production database before making modifications.
CASO Knowledge Base