Kofax - Bad Filename or Number Error During File Import

Applies to

Kofax Capture All

Summary

When importing an image, the following error is encountered: "An error occurred while importing the file '[path to TIF image]' Bad filename or number."

Cause

This error, "Bad Filename or Number," can arise during the scanning or importing of images if the Temporary Image Storage location specified in the batch class is either not present or inaccessible due to insufficient permissions for the user account.

Answer/Solution

  1. On the workstation experiencing this issue, try accessing the path designated as the Temporary Image Folder in the Batch Class Properties.

  2. If the path is inaccessible or if Windows requests login credentials, it indicates that the current user lacks access to this folder.

  3. If access to the folder is successful, try to create a new file there. Inability to do so means the user account lacks 'Write' permission for the folder.

  4. If file creation is possible, try renaming an existing file or folder in that location. If renaming is not possible, the user account needs 'Modify' permission for that folder.

To resolve the issue, adjust the folder permissions or network sharing settings to grant the user account Read, Write, Modify, and Delete permissions. Alternatively, choose a different location for the Temporary Image Storage where the user already has the necessary permissions, update this in the Batch Class, and republish the batch class.

 

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